Hello Jeff,

Strange, now it's working, but I think I did not modify anything.
Maybe I missed a restart...

Friday, December 9, 2005, 12:21:47 PM, you wrote:

JR> Adam Groszer wrote:
>> I register a page with the following zcml:
>>   <browser:page
>>       name="index.html"
>>       for="..interfaces.IPerson"
>>       template="person_view.pt"
>>       permission="dkr.ListContent"
>>       menu="zmi_views" title="View"
>>       >
>>   </browser:page>
>> I can access it only through .../person01/@@index.html.
>> What am I missing? What do I have to do to access it as
>> .../person01/index.html?

JR> Now that's odd!  Here I can use @@index.html or index.html, @@contents.html
JR> or contents.html and view my own pages.  The @@ seems to make no difference,
JR> in the cases I'm trying.

JR> And sometimes when type in a URL to reference an object, say

JR>      http://localhost/myobject

JR> it add a /index.html suffix and displays in the browser URL widget as:

JR>      http://localhost/myobject/index.html

JR> and other times it doesn't.  Using firefox here.

JR> -Jeff

JR> _______________________________________________
JR> Zope3-users mailing list
JR> Zope3-users@zope.org
JR> http://mail.zope.org/mailman/listinfo/zope3-users

Best regards,
 Groszer Adam                            mailto:[EMAIL PROTECTED]
Quote of the day:
The great successful men of the world have used their imagination...they think 
ahead and create their mental picture in all its details, filling in here, 
adding a little there, altering this a bit and that a bit, but steadily 
building-steadily buildings. (Robert Collier)

Zope3-users mailing list

Reply via email to