-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Tom Dossis wrote:
> Tom Dossis wrote:
>>
>> Shane Hathaway wrote:
>>> Shane Hathaway wrote:
>>>> Was this an accident?  Did it work at one time?  Are there plans to
>>>> make
>>>> principal annotation views work again?  And how can I edit user
>>>> annotations in the meanwhile?
>>>
>>> No one knows, I guess.  After spending many days on a seemingly simple
>>> problem, I've drawn a blank.
>>
>> Not that I've tried this myself (yet).
>>
>> Re: the ZopeBook example, I'd change the annotation adapter from
>> IPrincipal to IInternalPrincipal..
>>
> 
> Alternatively, it may possible to setup an adapter for
> IInternalPrincipal to IPrincipal ?

I tried that first, but it got messy.  IPrincipal needs an id, but
InternalPrincipal doesn't know its own id; only the folder that contains
it knows.  However, the folder has no method for giving me the id of an
InternalPrincipal, so the encapsulation isn't complete.  Maybe I should
work harder in this direction anyway.

Your idea of annotating InternalPrincipals rather than Principals seems
to work, but I apparently did something wrong, because edited
annotations don't persist!  I can save edits, but when I reload the
page, they're gone.  I don't know why.

Thanks for helping me over a hurdle.  You'd think a Zope 2 veteran like
me would have little trouble with Zope 3, but I'm finding that I need to
get to know practically all of Zope 3 before I can really do anything
with it.  (I had to do the same thing with Zope 2.)

Shane

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFED+PVA+xzD9r1eLsRAj4dAJ9uE6irT2H/9a002HptQfxLXa51bACaAxwD
cRwvLUIEotx2Xkud4pTQYis=
=fkR8
-----END PGP SIGNATURE-----
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to