Thanks Fernando & Stephan

On 26/06/2007, at 11:19 AM, Stephan Richter wrote:
On Monday 25 June 2007 19:34, Fernando Correa Neto wrote:
On 6/25/07, Stephan Richter <[EMAIL PROTECTED]> wrote:
On Monday 25 June 2007 17:15, George Wright wrote:
An internal error occured due to a bug in either zc.buildout or in a
recipe being used:
No module named schemaless
That happened to me too. I don't know the reason but by unsetting my
PYTHONPATH environment variable solved the problem.
Usually my $PYTHONPATH points to my zope3.3.0 installation.
Unfortunately, I didn't have time to debug.
That is probably it! The Python path is inserted at the front of everything. That means that all your Zope 3.3.0 packages are preferred over the installed

OK. Just for the record here's what I did:
I reset the PYTHONPATH like this (on Mac OSX & bash) <export PYTHONPATH= >
Then ./bin/buildout went to completion
Then ./bin/demo fg worked beautifully
I stopped the server then quit 'Terminal' & restarted it - now PYTHONPATH was back to normal ie pointing to zope 3.3.0. The demo ran correctly again.

Question: Is it generally recommended that when installing eggs the PYTHONPATH temporarily be set to empty?

George Wright

Zope3-users mailing list

Reply via email to