On Jan 23, 2008 2:04 PM, Roger Ineichen <[EMAIL PROTECTED]> wrote:
> > No, I see the exact same thing on Mac and Linux; you need to
> > explicitly include .zcml and .txt files in MANIFEST.in; that
> > file doesn't exist; just create one next to setup.py, and
> > include 2 lines:
> >
> >   global-include *.txt
> >   global-include *.zcml
> >
> > This'll include *all* text and zcml files recursively found
> > from that directory.
> Are you really sure? that's new to me and that isn't documented
> here:
> http://svn.zope.org/*checkout*/Sandbox/philikon/foundation/releasing-softwar
> e.txt

Nope, it's a distutils feature: http://docs.python.org/dist/manifest.html

> Is this new or just a windows feature?
> And why does the eggs work on my windows machine without any issue?

Did you release the egg from a SVN checkout, or a SVN export? I
haven't experimented with this, but that's my current hypothesis, that
setuptools behaves differently then; that or a dev egg has been
created in a buildout and the .egg-info dir contains more information.

> Note I just released like we did before, older tags do not contain
> such a MANIFEST.in file.

It's how I solved the same problem recently with the release of
collective.captcha; the upload to pypi didn't have anything but the
README.txt and the python code; other text files and zcml were

> Note my output looks like this and contains all *.zcml files etc.
> Also the zip or if I use --format=tar.gz contain the files.
> I guess they only get not extracted from the zip or tar.gz file.
> On my machine everyting is there and the eggs works like expected
> if the come form pypi ;-)

Perhaps there is something different going on then; as I stated, I saw
what appears to be the same problem and it was solved by including a

Martijn Pieters
Zope3-users mailing list

Reply via email to