Followup2 to myself...

   I upgraded Postgres (7.0b5 to 7.0.2) and the problem magically went
away.

   Still, if anyone has an idea why Zope-PCGI could connect, while
Zope+ZServer couldn't - I'd be glad to hear.

On Sat, 15 Jul 2000, Oleg Broytmann wrote:
> Followup to myself...
> 
> On Sat, 15 Jul 2000, Oleg Broytmann wrote:
> >    I did an experiment (after having problems connecting Zope to Postgres)
> > - I stopped ZServer and restared Zope in PCGI-only mode.
> > 
> >    I opened connection successfully!
> > 
> >    I stopped PCGI and restarted ZServer. I again got BadRequest (cannot
> > connect to server).
> > 
> >    Anyone have an idea why Zope+ZServer cannot connect, while Zope-PCGI
> > can?
> > 
> >    Deeper investigation did not reveal any difference - environments are
> > the same, I can connect from command line, I can even import DB.py (from
> > the Database Adapter) and connect through it from command line...
> 
>    On different computer I did an experiment - and connected to MySQL
> pretty successfully from Zope+ZServer.
> 
>    Thoughts:
> 
> 1. MySQL vs. Postgres. No way - I can connect to Postgres from Zope-PCGI.
> 
> 2. MySQL DA vs. ZPygres DA. ZPygres DA is not ZServer (multithread) ready.
> 
> 3. Linux vs. Solaris; I run MySQL on Linux and Postgres on Solaris. But
> where is a difference? PyGreSQL compiled on Solaris with -R option and does
> not require LD_LIBRARY_PATH - the only difference I can think of.

Oleg.            (All opinions are mine and not of my employer)
---- 
    Oleg Broytmann      Foundation for Effective Policies      [EMAIL PROTECTED]
           Programmers don't die, they just GOSUB without RETURN.


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to