On the Paris sprint, one thing that was noted was how ironic it was
that the release of 2.8, which includes support for the new
recommended development paradigm, was held up becuase we neeeded to
support an old non-recommended one. :-)

Anyway, my main question is: You who are using ZClasses, can't you
just stay on Zope2.8 or 2.9, if Zope 2.10 would not contain ZClass
support? The main features of 2.8 is support for the component
architecture, and for zope 2.9 and 2.10 this will be even more true:
there will most likely be very few new features besides this. With 2.9
or 2.10 the idea is that you can use both  ZClasses, *and* write
products that work under Zope3. I'm not even sure there will be a
2.10, and in any case you won't really have much need of it.

I think it's a good idea to deprecate ZClasses if only to get people
to start moving over to the Zope3 based development paradigm.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to