What the heck! I get the exact same error with a fresh instance of
2.8.4!  Am I just not installing this correctly?  I've followed the
instructions in doc/README.txt.

I extract the contents of the tarball into my instance's Products directory.

I go into the extension_modules directory and run "python2.3 setup.py install"

It completes.  I enter a python2.3 interactive shell and can "from
zopyx import txng3" without error. The libraries were installed in
/usr/local/lib/python2.3/site-packages.

This python is the same one used for this installation of Zope.

The TextIndexNG3 directory tree is accessible by the zope user.

After restarting Zope, it shows up in the Products list normally (not broken).

When trying to add a TextIndexNG3 to my ZCatalog is thows a
"ComponentLookupError".

Could there be a problem with our installation of python?  It's
currently used, seemingly without trouble, in two existing
installations of Zope (different versions).  The server is running two
2.8.0 instances and one 2.8.4 instance.  This is a newly created
second 2.8.4 instance to try resolve my TextIndexNG problems.

Is there anything I can do to verify or confirm that whatever
TextIndexNG is looking for is actually broken or missing?

-------------------
Zope Version (Zope 2.8.4-final, python 2.3.5, linux2)
Python Version 2.3.5 (#2, Jul 13 2005, 15:31:52) [GCC 3.2.3 20030502
(Red Hat Linux 3.2.3-52)]
System Platform linux2
SOFTWARE_HOME /usr/local/Zope/2.8.4-final/lib/python
ZOPE_HOME /usr/local/Zope/2.8.4-final
INSTANCE_HOME /usr/local/Zope/2.8.4-final/instances/clients
CLIENT_HOME /usr/local/Zope/2.8.4-final/instances/clients/var

-------------------
Traceback (innermost last):
  Module ZPublisher.Publish, line 113, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 40, in call_object
  Module Shared.DC.Scripts.Bindings, line 311, in __call__
  Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
  Module Products.PageTemplates.PageTemplateFile, line 110, in _exec
  Module Products.PageTemplates.PageTemplate, line 104, in pt_render
   - <PageTemplateFile at /test/catalog/manage_addTextIndexNG3Form>
  Module TAL.TALInterpreter, line 206, in __call__
  Module TAL.TALInterpreter, line 250, in interpret
  Module TAL.TALInterpreter, line 651, in do_loop_tal
  Module Products.PageTemplates.TALES, line 206, in setRepeat
  Module Products.PageTemplates.TALES, line 221, in evaluate
   - URL: manage_addTextIndexNG3Form
   - Line 155, Column 8
   - Expression: standard:'context/get_splitters'
   - Names:
      {'container': <App.ProductContext.__FactoryDispatcher__ object
at 0xb62658ac>,
       'context': <App.ProductContext.__FactoryDispatcher__ object at
0xb62658ac>,
       'default': <Products.PageTemplates.TALES.Default instance at 0xb6c4af0c>,
       'here': <App.ProductContext.__FactoryDispatcher__ object at 0xb62658ac>,
       'loop': <Products.PageTemplates.TALES.SafeMapping object at 0xb62290cc>,
       'modules':
<Products.PageTemplates.ZRPythonExpr._SecureModuleImporter instance at
0xb6c5afac>,
       'nothing': None,
       'options': {'args': ()},
       'repeat': <Products.PageTemplates.TALES.SafeMapping object at
0xb62290cc>,
       'request': <HTTPRequest,
URL=http://localhost:8081/test/catalog/manage_addProduct/TextIndexNG3/manage_addTextIndexNG3Form>,
       'root': <Application at >,
       'template': <PageTemplateFile at
/test/catalog/manage_addTextIndexNG3Form>,
       'traverse_subpath': [],
       'user': admin}
  Module Products.PageTemplates.Expressions, line 185, in __call__
  Module Products.PageTemplates.Expressions, line 180, in _eval
  Module Products.PageTemplates.Expressions, line 85, in render
  Module Products.TextIndexNG3, line 49, in get_splitters
  Module zope.component, line 87, in getUtilitiesFor
  Module zope.component, line 68, in getService
  Module zope.component.service, line 109, in getService
ComponentLookupError: 'Utilities'



On 12/5/05, Garth B. <[EMAIL PROTECTED]> wrote:
> Sigh... figures... I'll use this as an excuse to upgrade to 2.8.4
>
> Thanks!
>
> On 12/5/05, Andreas Jung <[EMAIL PROTECTED]> wrote:
> >
> >
> > --On 5. Dezember 2005 14:15:39 -0500 "Garth B." <[EMAIL PROTECTED]> wrote:
> >
> > > Sorry, I created a ZCatalog and when choosing TextIndexNG3 from the
> > > "Add" dropdown in my ZCatalog's Indexes tab, it immediately gives me
> > > this error.
> >
> > Works like a charm..Somehow your Zope installation must be borked.
> > Try with again with a fresh 2.8 installation.
> >
> > -aj
> >
> >
> >
>
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to