"Paul Winkler" <[EMAIL PROTECTED]> wrote in
message news:[EMAIL PROTECTED]
> I spent several hours recently to import a .zexp of a Plone 2.0 site.
> Got nowhere.
> One suggestion I got (which I wasn't able to follow) was the
> following.  If you have access to the original server, try this:
> 1) Make a full backup of the entire ZODB, eg. using repozo.py.
> 2) Set up a new Zope instance with all the same products installed,
> using your new backup copy of the ZODB.
> 3) Go into the ZMI for this new instance, and delete everythign EXCEPT
> plone site.
> 4) Pack the database to get rid of all the other stuff.  Or make a new
> clean backup.
> There. You now have a Data.fs that contains only your Plone site.
> Instead of importing the .zexp, just mount the database at the
> appropriate path.
> Disclaimer: I haven't tried this yet.

Thanks Paul. Someone else on another list also suggested this method and I
tried it and it seems to work well. To make it work, there are a couple of
additional bits that need to be followed:

5) Go back to the orignal Zope instance and delete the Plone site that you
want to set up the new file storage for (make a backup first)
6) Make sure that the new mount point has the same name as the original
Plone site in zope.conf

Then when you create the new ZODB mount point, it will appear in the root of
the ZMI as a Plone site just as before so there's not even any need to to
re-create the catalogue.



Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to