Andreas Jung wrote:

--On 20. Juni 2007 21:58:18 -1000 John Schinnerer <[EMAIL PROTECTED]> wrote:
Thanks...I have no idea how to do that unfortunately.
This is the first time I've built python from source. I just followed the
build instructions in the tarball and "it worked." At least, I have a
working python 2.3 in the location I specified for "--with-python" when
building zope.
 From various list messages about this same error message I get that
there is some mismatch involving UCS2 vs. UCS4 compiled pieces - if I
grok correctly...?


If you install Python using

 configure --prefix=/opt/python-2.4; make;make install

and configure Zope using

 configure --with-python=/opt/python-2.4/bin/python2.4; make; make install

you should never get into such trouble. Somehow your environment or setup
must be broken. Possibly you're installing Zope over an existing Zope installation with possibly old zopectl/runzope files inside the 'bin' folder which won't be replaced by "make install". So check the "python" configuration within your bin/zopectl|runzope files.

Thanks again - the above is what I thought I did (matching the --prefix and the --with-python) - however somewhere I blew it somehow as the control files point to the wrong python.
I'll try again and hopefully get it right. Thanks for the extra assist.

John S.

John Schinnerer, MA WSD
- Eco-Living -
Whole Systems Design Services
People - Place - Learning - Integration
Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to