Dieter Maurer wrote:
Yuri wrote at 2008-3-26 11:19 +0100:
I've got a trouble importing a ZClass app to 2.9.8 from 2.6.1.

First, I've tried 2.8, and it worked but had the __new__ problem, so I've seen it is fixed in 2.9.8.

After the upgrade, all seemed to work. My ZClass is a container (with ExtFile). I've been able to create a new instance, then had trouble after uploading an ExtFile. The file is there, in the repository, but when I clicked over it, I get a fast scrolling in the log. After the restart, the ZClass instances and the Product in the control panel, gived me a maximun recursion depth, here the last part:

File "/usr/lib/zope2.9.8/lib/python/ZODB/", line 597, in getState
   return unpickler.load()
 File "logging/", line 1078, in _log
 File "logging/", line 1064, in makeRecord
 File "logging/", line 226, in __init__
   # Must happen after ZopeStarter.setupInitialLogging()
RuntimeError: maximum recursion depth exceeded in cmp

This is very strange: the traceback you show does not seem very deep.
It should not raise a "maximum recursion depth exceeded".

I deleted the long first part, always equal to the last one. Does it matter? :)

As always: when you see something which should not be there, debugging
may be necessary for understanding...

I agree. But it works, until you restart then this error happen forever.

How can I debug this?

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to