I followed the instructions from the howto, including the mount point part.
I have a folder named 'session_folder' in my root, and it containts a 
session data manager. There are also items in there when sessions are 
being used so it looks like that's functioning fine.

Are the sessions ID's not consistent accross clients or is this some 
kind of bug?

Allen Schmidt Sr. wrote:
> Do you have the ZODB mount point set up and pointing to your 
> session_folder?
> Marko Kruijer wrote:
>> That's not my problem, the session is in it's own .fs file, and it is 
>> persistent.
>> The problem is that the two zope clients use different sessions id's 
>> for the same user, that's not supposed to happen imo.
>> Allen Schmidt Sr. wrote:
>>> What we did was create a Session.fs and added to the zope and zeo 
>>> conf files. Then after restarting the zopes and zeo, in the ZMI, 
>>> create a ZODB mount point and it should see the Session.fs and build 
>>> the parts in the root of the ZMI that you need. Been a long time but 
>>> I think those are the steps. That way the session data is its own 
>>> data.fs file and is persistent across zopes and restarts, etc. The 
>>> problem is that it IS a data.fs file and therefore an undoing 
>>> storage. You will have to pack it the same as your main data file. 
>>> Not a big deal for us as its not used much. Just pack back a couple 
>>> days so you don't whip any session data that could be going on at 
>>> that moment.
>>> Anyone please chime in if I am missing something. Just taking a shot 
>>> at an answer based on our set up.
>>> Your mileage may vary.
>>> Allen
>>> Marko Kruijer wrote:
>>>> I'm maintaining a ZEO cluster setup that currently consists of 2 
>>>> Zope clients and 1 ZEO server (Zope version is 2.10.5.)
>>>> I'm using sessions on the hosted site and am having trouble sharing 
>>>> them across the 2 servers.
>>>> I've done a config as described here: 
>>>> Everything runs fine, except my sessions 'change' randomly. For 
>>>> example if I output my SESSION data I notice that the sessions ID 
>>>> is not persistent over i.e. 10 page loads.
>>>> The contents of the sessions also change, of course.
>>>> Am I missing something here? The central storage of the sessions 
>>>> should fix this if i'm correct, but it doesn't.
>>>> Is this impossible to do, or is another issue causing this stange 
>>>> behaviour?
>>>> best regards,
>>>> Marko
>>>> _______________________________________________
>>>> Zope maillist  -
>>>> **   No cross posts or HTML encoding!  **
>>>> (Related lists -
>>>> )







        T +3120 462 60 60
F +3120 462 60 20       WWW.OKTOBER.NL

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to