> 1. Sounds good.
> 2. It's exactly what I'm talking about, since it's called getTypeInfo...() and
> not createType...() it looks like a noop. It does actually do something which
> is also described in the previous line comments: "// ask for the type of the
> root element to populate the cache with anonymous types". That's why I want to
> keep the createType.. name.
Ah, thanks for the clarification. But I had the same question even before I
changed the names. So, to me at least, the createType...() name gives no
indication about the side effect. And the comment did not help either because
since the method does return a type, I thought the caller was supposed to take
*that* type and then put it into the cache himself. I will take a closer look
at the code and see if I can up with a better solution.
Your team Zorba Coders is subscribed to branch lp:zorba.
Mailing list: https://launchpad.net/~zorba-coders
Post to : firstname.lastname@example.org
Unsubscribe : https://launchpad.net/~zorba-coders
More help : https://help.launchpad.net/ListHelp