Re: sqlite 3.8.11.1

2015-09-09 Thread Miod Vallat
> Hi, > > thanks to the hard work of jturner@, here's a 650kb gzipped update to > sqlite 3.8.11.1, bumping shlib to 31.0. This is needed for upcoming > firefox 41 update, but anyone is welcome to look into the update itself. > > Not attaching the diff because of the size, available at >

Re: sqlite 3.8.11.1

2015-09-09 Thread Bob Beck
Why do we have unreviewable diffs to software in base? On Wed, Sep 09, 2015 at 10:25:24AM +0200, Landry Breuil wrote: > Hi, > > thanks to the hard work of jturner@, here's a 650kb gzipped update to > sqlite 3.8.11.1, bumping shlib to 31.0. This is needed for upcoming > firefox 41 update, but

Re: sqlite 3.8.11.1

2015-09-09 Thread Theo de Raadt
> > Not attaching the diff because of the size, available at > > http://rhaalovely.net/~landry/stuff/sqlite-3.8.11.1.diff.gz > > And i forgot to mention that it went in an amd64 bulk build without > fallout, thanks to ajacoutot@ So, one architecture has been tested. Now there is a request for

sqlite 3.8.11.1

2015-09-09 Thread Landry Breuil
Hi, thanks to the hard work of jturner@, here's a 650kb gzipped update to sqlite 3.8.11.1, bumping shlib to 31.0. This is needed for upcoming firefox 41 update, but anyone is welcome to look into the update itself. Not attaching the diff because of the size, available at

Re: sqlite 3.8.11.1

2015-09-09 Thread Theo de Raadt
This is a really stupid way to treat the base source tree. > thanks to the hard work of jturner@, here's a 650kb gzipped update to > sqlite 3.8.11.1, bumping shlib to 31.0. This is needed for upcoming > firefox 41 update, but anyone is welcome to look into the update itself. > > Not attaching

syslogd: less global, more malloc, more random

2015-09-09 Thread Alexander Bluhm
Hi, Instead of having global variables containing the libevent structures, allocate them with malloc. This makes the address space layout more random. ok? bluhm Index: usr.sbin/syslogd/syslogd.c === RCS file:

syslog(3) message length

2015-09-09 Thread Alexander Bluhm
Hi, Now syslogd can handle 8192 bytes per message. I think we should increase the libc syslog(3) limit to the same size. The buffer needs one byte more as it conains a NUL byte that sendsyslog(2) does not process. ok? bluhm Index: lib/libc/gen/syslog_r.c

Re: mkhybrid minor fixes

2015-09-09 Thread Miod Vallat
> Looks good to me, though I wonder if the "check for char less than > zero" tests should be replaced with isascii((unsigned char)x), as that > smells like the intent. Indeed, especially since other ctype functions are used after that test. New diff also including feedback from jca@. Also, we do

openssl(1) remove redundant defines

2015-09-09 Thread Lawrence Teo
This diff removes redundant defines in two files. In s_socket.c, SOCKET_PROTOCOL is defined as IPPROTO_TCP, but it's only used once. In s_time.c, NO_SHUTDOWN is always defined, so there is no need for a bunch of NO_SHUTDOWN #ifdef blocks. No binary change. ok? Index: s_socket.c

Re: arpproxy() & global list of interfaces

2015-09-09 Thread Martin Pieuchot
On 03/09/15(Thu) 11:14, Martin Pieuchot wrote: > In the IPv4 forwarding case your kernel checks if its is doing ARP proxy > for the destination to decide if it needs to send an ICMP redirect msg. > > Currently arpproxy() does an iteration on the global list of interfaces. > This will be not

Re: openssl(1) remove redundant defines

2015-09-09 Thread Todd C. Miller
On Wed, 09 Sep 2015 10:02:17 -0400, Lawrence Teo wrote: > This diff removes redundant defines in two files. > > In s_socket.c, SOCKET_PROTOCOL is defined as IPPROTO_TCP, but it's only > used once. OK. > In s_time.c, NO_SHUTDOWN is always defined, so there is no need for a > bunch of

Re: sqlite 3.8.11.1

2015-09-09 Thread Miod Vallat
> > When espie@ imported sqlite he wanted to follow upstream so he imported > > what was distrubuted with sqlite. Since then we do tagged (based on the > > sqlite version) imports whenever we do an update. So when a diff is sent > > out it includes all new files in that sqlite release. In this

Plug memory leak in ntpd(8)

2015-09-09 Thread Michael McConville
Found with the Clang static analyzer. Index: constraint.c === RCS file: /cvs/src/usr.sbin/ntpd/constraint.c,v retrieving revision 1.14 diff -u -p -r1.14 constraint.c --- constraint.c18 Jul 2015 21:50:47 - 1.14 +++

Re: mkhybrid minor fixes

2015-09-09 Thread Todd C. Miller
On Wed, 09 Sep 2015 13:50:21 -, Miod Vallat wrote: > New diff also including feedback from jca@. Also, we do not need to > embed the GNU getopt implementation anymore, since libc's getopt grew > support for long options quite many years ago. OK, but please remove the cast of the calloc()

[no subject]

2015-09-09 Thread James Turner
espie@openbsd, dera...@cvs.openbsd.org Bcc: Subject: Re: sqlite 3.8.11.1 Reply-To: In-Reply-To: <20150909084510.gh30...@tazenat.gentiane.org> On Wed, Sep 09, 2015 at 08:45:10AM +, Miod Vallat wrote: > > Hi, > > > > thanks to the hard work of jturner@, here's a 650kb gzipped update to > >

Re: openssl(1) remove redundant defines

2015-09-09 Thread Brent Cook
On Wed, Sep 9, 2015 at 10:15 AM, Todd C. Miller wrote: > On Wed, 09 Sep 2015 10:02:17 -0400, Lawrence Teo wrote: > >> This diff removes redundant defines in two files. >> >> In s_socket.c, SOCKET_PROTOCOL is defined as IPPROTO_TCP, but it's only >> used once. > > OK. >

Remove NULL checks before free()

2015-09-09 Thread Michael McConville
There will probably be more similar patches to come if this is acceptable. The legwork was done with the following Coccinelle script: @@ expression E; @@ - if(E) { - free(E); - } + free(E); Index: bin/systrace/filter.c ===

Re: syslogd: less global, more malloc, more random

2015-09-09 Thread Todd C. Miller
On Wed, 09 Sep 2015 13:14:16 +0200, Alexander Bluhm wrote: > Instead of having global variables containing the libevent structures, > allocate them with malloc. This makes the address space layout > more random. That huge if() makes things a bit harder to read. Doing the NULL check separately

Re: your mail

2015-09-09 Thread Stuart Henderson
On 2015/09/09 11:33, James Turner wrote: > espie@openbsd, dera...@cvs.openbsd.org > Bcc: > Subject: Re: sqlite 3.8.11.1 > Reply-To: > In-Reply-To: <20150909084510.gh30...@tazenat.gentiane.org> > > On Wed, Sep 09, 2015 at 08:45:10AM +, Miod Vallat wrote: > > > Hi, > > > > > > thanks to the

Re: Plug memory leak in ntpd(8)

2015-09-09 Thread Todd C. Miller
On Wed, 09 Sep 2015 10:41:07 -0400, Michael McConville wrote: > Found with the Clang static analyzer. Committed, thanks. - todd

Re: Remove NULL checks before free()

2015-09-09 Thread Nicholas Marriott
Hi I personally don't see a particular need for this, it's something that can be tidied up as people make other changes in the area. Certainly you are trying to touch a lot of different places at once here which is usually not the best approach even for something minor. You'd probably be better

Call for testers of restricted rmt(8)

2015-09-09 Thread Alexander Hall
I'm going wide with this diff I've been pushing for quite some time now. Is *anyone* but me using rdump(8) + rmt(8)? *If you are currently using rdump/rrestore + rmt, I urge you to test this diff to make sure it causes no regression. It shouldn't, but you've been warned. So, anyway, this diff

Re: [patch] fix sdmmc bug affecting strictly sector-addressable eMMC chips

2015-09-09 Thread kremlin
This message is in response to this previous discussion: http://marc.info/?l=openbsd-tech=144074914604130 >> Since sector mode is supported by the host software, shouldn't we >> always set the MMC_OCR_SECTOR_MODE bit and check the returned OCR >> value to see if the card also supports sector

Re: first step of ix(4) without kernel lock

2015-09-09 Thread Hrvoje Popovski
On 9.9.2015. 10:10, Claudio Jeker wrote: > This is a port of the em(4) IPL_MPSAFE changes made by kettenis@ to ix(4). > Seems to work for me but don't expect any miracles. > > Please test > Hi, i am testing your patch with bridged and routed setup and everything works nice. ix card is dual

ksh INT32 type

2015-09-09 Thread Michael McConville
I may be totally off base here, but: INT32's comment suggests that the configure script checks that int is >= 32 bits. However, i don't think that script's around anymore, and ANSI specifies a minimum of only 16 bits. The comment also says that INT32 can be 64 bits, but it's then used as Tflag,

Re: openssl(1) remove redundant defines

2015-09-09 Thread Lawrence Teo
On Wed, Sep 09, 2015 at 11:17:55AM -0500, Brent Cook wrote: > On Wed, Sep 9, 2015 at 10:15 AM, Todd C. Miller > wrote: > > On Wed, 09 Sep 2015 10:02:17 -0400, Lawrence Teo wrote: > >> In s_time.c, NO_SHUTDOWN is always defined, so there is no need for a > >> bunch of

Re: your mail

2015-09-09 Thread Gilles Chehade
unrelated to this topic, I suspect your smtpd is fairly old right ? On Wed, Sep 09, 2015 at 11:33:57AM -0400, James Turner wrote: > espie@openbsd, dera...@cvs.openbsd.org > Bcc: > Subject: Re: sqlite 3.8.11.1 > Reply-To: > In-Reply-To: <20150909084510.gh30...@tazenat.gentiane.org> > > On Wed,

Re: ping6: out of boundary access with invalid packets

2015-09-09 Thread Florian Obser
On Tue, Sep 08, 2015 at 09:45:06PM +0200, Tobias Stoeckmann wrote: > The function pr_pack does not properly check boundaries before > accessing packet data. This could happen on short network reads or > when we receive packets that are addressed for another running ping6 > instance (see pr_pack

Re: sqlite 3.8.11.1

2015-09-09 Thread Amit Kulkarni
On Wed, Sep 9, 2015 at 11:12 AM, Miod Vallat wrote: > > > When espie@ imported sqlite he wanted to follow upstream so he > imported > > > what was distrubuted with sqlite. Since then we do tagged (based on the > > > sqlite version) imports whenever we do an update. So when a diff

Re: syslogd: less global, more malloc, more random

2015-09-09 Thread Todd C. Miller
On Wed, 09 Sep 2015 18:57:05 +0200, Alexander Bluhm wrote: > Hmm, then you have another list where you can forget one of them. > ev_listen, ev_unix, ev_hup are missing in your example. Yeah, that is the downside. Looks like I deleted a little too much. - todd

Re: syslogd: less global, more malloc, more random

2015-09-09 Thread Alexander Bluhm
On Wed, Sep 09, 2015 at 08:55:12AM -0600, Todd C. Miller wrote: > On Wed, 09 Sep 2015 13:14:16 +0200, Alexander Bluhm wrote: > > > Instead of having global variables containing the libevent structures, > > allocate them with malloc. This makes the address space layout > > more random. > > That

Re: your mail

2015-09-09 Thread James Turner
On Wed, Sep 09, 2015 at 06:13:11PM +0200, Gilles Chehade wrote: > unrelated to this topic, I suspect your smtpd is fairly old right ? > Running a snapshot from 9/2. > On Wed, Sep 09, 2015 at 11:33:57AM -0400, James Turner wrote: > > espie@openbsd, dera...@cvs.openbsd.org > > Bcc: > > Subject:

Re: your mail

2015-09-09 Thread James Turner
On Wed, Sep 09, 2015 at 06:13:11PM +0200, Gilles Chehade wrote: > unrelated to this topic, I suspect your smtpd is fairly old right ? > If this is about my fucked up response I think that was all on me and a failed Mutt reply. > On Wed, Sep 09, 2015 at 11:33:57AM -0400, James Turner wrote: > >

Re: sqlite 3.8.11.1

2015-09-09 Thread Stuart Henderson
On 2015/09/09 11:47, Amit Kulkarni wrote: > AFAIK, the original rationale for importing sqlite into base was for > storing the database table (INDEX?) for building ports using dpb. It > can be switched to a port module with some pains. mandoc uses it.

Re: sqlite 3.8.11.1

2015-09-09 Thread Ingo Schwarze
Hi, Stuart Henderson wrote on Wed, Sep 09, 2015 at 05:51:18PM +0100: > On 2015/09/09 11:47, Amit Kulkarni wrote: >> AFAIK, the original rationale for importing sqlite into base was for >> storing the database table (INDEX?) for building ports using dpb. It >> can be switched to a port module