Got it working. The fix was to use the Admin account in the Log On tab. That 
also fixed the Xojo WebApp. The fix did take until the server machine was 
restarted. I also opened 4D server and database as Administrator before 
restarting the computer.

Looks like Interactive desktop only works with Local System account checked. 
Bummer.

Thanks for all who helped.

John



> On May 10, 2019, at 3:50 AM, Tim Nevels via 4D_Tech <4d_tech@lists.4d.com> 
> wrote:
> 
> On May 10, 2019, at 8:09 AM, JOHN BAUGHMAN wrote:
> 
>> Tim,  thank you for that most informative post. It really helps. I will be 
>> switching my client's 4D Server to a service later this evening for the 
>> first time. After reading your post I feel far more confident going forward.
>> 
>> The client is running v16R6 on Windows Server 2008 R2. You pointed me in the 
>> right direction and it appears in this configuration Interactive Services 
>> works great. I suspect that the client will continue using Win Server 2008 
>> until they are forced to upgrade, but I will be moving them to v17 shortly. 
>> Hopefully Interactive Services will continue to work with v17.
> 
> Windows Server 2008 R2 fully supported interactive desktop, so no need for 
> Registry entry modifications there. 
> 
> But be warned that you may still run into an issue with how you “Log on as:” 
> in the “Log on” tab in the Services dialog for 4D Server in the Services 
> window. 4D or Microsoft changed something and I had an issue upgrading from 
> 4D Server v12 to v16 on Windows Server 2012. 
> 
> https://dl.dropboxusercontent.com/s/w6d63gpm5rn5mp7/Services%20Log%20On.PNG
> 
> Normally you just select the default “Local System account” and it works. But 
> when I  did a v12 to v16 upgrade it would not work. Pat Bensky also recently 
> had this same problem. The solution is to switch to “This account:” and use 
> an administrator account. But — and Pat will tell you this — be careful how 
> you specify the account name. It’s not just something like “timnevels” it may 
> be “\domain\timnevels”. Use the “Browse” button to find the account name and 
> it will put it in a form that works. 
> 
> Also, you may need to “Run as administrator” the 4D Server.exe to be able to 
> access “Register Current Database as Service” in the File menu of 4D Server. 
> If the item is disabled, you need to run as administrator. 
> 
> One last tip, if you can, since this is a new switch from macOS to Windows, 
> and if you have ready access to the server machine, start off by NOT running 
> 4D Server as a Windows Service. Run it as a desktop application. You can do 
> the Services setup and try it out, but Stop the service mark the service as 
> “Manual” when you are done setting it up and testing. 
> 
> Save running as a Service for a few days. Make sure there are no unexpected 
> issues with this macOS to Windows conversion. It’s much more convenient and 
> removes some variables if you just run 4D Server from the Desktop. You can 
> remote to the server and see what is going on without having do the 
> interactive services switch dance. Once things are running smoothly, then you 
> can switch to running as a Service. Any new problems might then be explained 
> as connected to running the database as a Service and not just “worked fine 
> on a macOS server but on Windows server it doesn’t work, so it’s a Windows 
> server problem”. 
> 
> Sometimes printing — like creating PDFs on the server — can be an issue when 
> running as a Service. 
> 
> Tim
> 
> *****************************************
> Tim Nevels
> Innovative Solutions
> 785-749-3444
> timnev...@mac.com
> *****************************************
> 
> **********************************************************************
> 4D Internet Users Group (4D iNUG)
> Archive:  http://lists.4d.com/archives.html
> Options: https://lists.4d.com/mailman/options/4d_tech
> Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
> **********************************************************************

**********************************************************************
4D Internet Users Group (4D iNUG)
Archive:  http://lists.4d.com/archives.html
Options: https://lists.4d.com/mailman/options/4d_tech
Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
**********************************************************************

Reply via email to