John:

I see that Tim surfaced this in another thread.


--
Douglas von Roeder
949-336-2902


On Fri, May 10, 2019 at 1:20 PM Douglas von Roeder <dvonroe...@gmail.com>
wrote:

> John:
>
> I have one system that’s a built app that runs as a service. Maybe this
> applies to your situation.
>
> When I put out a new structure, I launch the app by choosing the .exe, do
> a right mouse and select “Run as administrator”, select the datafile, and
> let the app launch. Once it’s running, I launch the built client app,
> ensure that the update runs, and then quit the client app. That sequence
> ensures that the server has the data file path, that it can respond to
> requests, that it can serve the new code, and that the client can update
> and connect.
>
> Next step is to quit 4D Server, start the service running, and log into it
> with the built client app.
>
> I realize that the built server/client is a little different but maybe
> launching the server manually would help in your situation.
>
> --
> Douglas von Roeder
> 949-336-2902
>
>
> On Fri, May 10, 2019 at 1:04 PM JOHN BAUGHMAN via 4D_Tech <
> 4d_tech@lists.4d.com> wrote:
>
>> Well, last night I tried to start the service on the client’s production
>> machine and I could not get it to work.
>>
>> After registering the service from 4D server, I tried starting the
>> service from the Service Manager and it indicated that it had started up
>> but I was unable to establish a connection using a 4D client. On my VM
>> Interactive Services takes a while to show up in the task bar after a
>> restart, but it eventually does. On the production server, it never makes
>> an appearance. So I have no other way to see it the server is running
>> properly.
>>
>> I then restarted the computer with the service set to start
>> automatically. Again I was unable to establish a connection with 4D Client.
>> I tried both manually and automatically a few times without success. Each
>> time I tried to start up 4D Server normally and on at least one occasion 4D
>> asked if I wanted to open the database in Read Only mode, which tells me
>> the service had opened the datafile. On other tries, I was able to open the
>> database normally.
>>
>> A couple of other things to note.
>>         1. A year or so ago I was investigating the ins and outs of
>> running as a service on this same machine and I was able to get everything
>> to work.
>>
>>         2. I have the service 4D’s Application Server listening on port
>> 19816 as I have another 4D server running a different database on the same
>> box opened normally (not as a service) listening on port 19813. It only
>> opens after the Admin user logs in. They both work fine together when both
>> are opened normally.
>>
>>         3. The service 4D is also running a web server which respond to
>> requests from a Xojo WebApp running on the same machine. Those requests
>> fail when 4D Server is supposedly
>> running as a service.
>>
>>         5. Finally of note is that when the Xojo WebApp is opened as a
>> Service it will not open as it unexpectedly quits on startup. All of this,
>> Xojo and 4D Server work just fine on my VM and all worked fine a year ago
>> when I first started researching things on the production machine. The
>> folks at Xojo suggest that my WebApp may be trying to access a file that
>> the service does not have access to. Tonight I will be trying to get the
>> Xojo service to work with no file access queries in the WebApps startup
>> events.
>>
>> I think that the inability to start both the Xojo WebApp and 4D as
>> services is related and may be encountering an issue with the OS, which may
>> have different updates than my VM. The production machine has been
>> religiously updated by windows over the year,, my VM not so much.
>>
>> Any suggestions?
>>
>> Thanks,
>>
>> John
>>
>> **********************************************************************
>> 4D Internet Users Group (4D iNUG)
>> Archive:  http://lists.4d.com/archives.html
>> Options: https://lists.4d.com/mailman/options/4d_tech
>> Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
>> **********************************************************************
>
>
**********************************************************************
4D Internet Users Group (4D iNUG)
Archive:  http://lists.4d.com/archives.html
Options: https://lists.4d.com/mailman/options/4d_tech
Unsub:  mailto:4d_tech-unsubscr...@lists.4d.com
**********************************************************************

Reply via email to