Peter, not sure what parts of this might be useful, so I'll try to keep it 
brief.  Let me know if you want more details about anything.

Coming to you from Firefox running on F27 4.15.2-301.aarch64 running on a 
Raspberry Pi 3B.  Xfce4 as GUI.

Last two installs (over the last week or so) were from the F27 link to aarch64 
downloads, and I used the Workstation download in both cases: 

The base 4.13 install was pretty unusable through the GUI.  System crashed 
after initial setup as it was trying to bring up the login screen.  Power 
cycled and it came up with the GUI screen.  GUI performance was so slow that I 
presumed it was hung; might have just been performance, though.  Login via ssh 
from Mac worked.   Did a dnf update to get to 4.14.18-300 and when I rebooted 
got black screen (no login GUI); load was 0.01, so it was idle but graphical 
not working.  I assumed that the 4.4.18 update broke X.  Installed the 4.15 
rpms ref'd here and got the black screen on boot.  But in all those cases, 
could get to the system via ssh from my Mac.  Performance for routine tasks 
similar to SUSE Leap 42.3.  On 4.15, using nmcli, was able to get WiFi working 
routinely.  So the biggest issue was the GUI -- which is a problem if you're 
trying to run the workstation environment.  :-)

After meeting yesterday, did a fresh install of F-Workstation-27-1.6-aarch64 to 
get the initial 4.13 kernel.  Again, slow GUI; did setup; system restarted GUI 
and brought up login screen successfully, but system hung when I logged in.  
Rebooted through power cycle and worked from Mac via ssh.  Transferred over the 
4.15 rpms and the brcm...txt file needed for WiFi (copied from site Paul 
ref'd).  INSTALLED 4.15 DIRECTLY, AVOIDING 4.14 UPDATE.  Came up with GUI on 
reboot.  THEN did dnf update.  Reboot, & GUI still works -- but is still very 
slow.  Used GUI interface to set up WiFi: works. Did a "systemctl set-default 
multi-user.service" and rebooted to get rid of GUI login screen.  Did a dnf 
groupinstall "xfce workstation".  On console, did startxfce4 and got a usable 
GUI.  Slower than OpenSUSE Leap 42.3 but usable and stable.  Exited and tried 
Worg ... hung screen. 

My tentative conclusion is that the Worg stuff is unusable at this point and 
that I'm better sticking with xfce.  I'll try a clean install of minimal and 
then install xfce to see if that results in an even more stable and reliable 
workstation envt. 

4.15 boots from either USB or microSD on the RPi-3B.  The RPi-3B will boot from 
the microSD card or from a USB drive if it has been prepared (one-time process) 
to so.  F27-4.15 will boot from either.  (I use a microSD and microSD-USB 
adapter so the same card is used with different interfaces).  Timings are 
comparable, but USB *seems* to boot a bit faster (54 sec vs 60 for microSD).  
But the good news is that you COULD do the initial dd copy onto a 
USB-interfaced SSD, resize the / partition with gparted on a host, and then 
boot the RPi directly from the SSD drive if you wanted, with no extra finagling 

I'll follow up with more info if my minimal install / 4.15 update / xfce 
install is successful.


arm mailing list --
To unsubscribe send an email to

Reply via email to