Steven Vanden Branden schreef op za 14-04-2018 om 16:47 [+0000]:
> hello everyone,
> thanks for the assistance, but i managed to load the new kernel with
> the old dtb file for the inet1,
> I made a diff between the new and old version , and there are a lot
> of changes, even gpio pins for that are changed (which i find
> strange, since the original device cannot be changed i guess, maybe
> gpio pin is changed in the dtsi files), and is suspect that new
> hardware is supported on the inet1, that now breaks my hacked
> together version using the inet1 dtb file.
> but it turns out i need to spend time to add support for my board in
> uboot and in the kernel as well (mostly dts work i guess).
> So if you have any tips/guidance on how to go about adding a new
> board (first in uboot i guess , then kernel), i would like to know.
> Greetings,
> Steven

when i enable the original dtb file, the board is now working, I am
however succeeded in soldering a serial connection to the board.

The only strange thing is when i send from one side:

echo -en '\x00' > /dev/ttyS0          i receive 0x00 in hex
echo -en '\x01' > /dev/ttyS0          i receive 0x7F in hex

--> this makes the serial output unreadable since the mapping of
characters seems to be off, does anyone has an idea how to fix this?

--> i tried this with a baudrate of 300 to be sure the connection is

--> i tried to attach my serial output to the input of the pc and that
return fine, so it seems the 2 serial ports are actually speaking
another dialect.

> _______________________________________________
> arm mailing list --
> To unsubscribe send an email to
arm mailing list --
To unsubscribe send an email to

Reply via email to