We're not yet able to setup Ubuntu native on PC's at work, so we're using 
Ubuntu under VBOX.

I'm attempting to do JTAG debugging via CCS 7.2 to the BB-X15/am572xEVM, 
but when I run CCS in debug mode under an Ubuntu/VirtualBox, CCS hangs. 
 I'm able to view registers on the A15_0 core, but I haven't been able to 
successfully load u-boot-spl.bin built in CCS on Ubuntu.  When I load, CCS 
never comes back, and I haven't been able to specify the "load address" for 
the SPL.  From what I understand from reading an older version of TI's CCS 
wiki, JTAG debugging doesn't work well through a virtual machine.

So I'm trying a strange approach:  2, CCS 7.2 installations on the same 
machine, 1 under the Ubuntu VM to build the SPL in Linux and another under 
Windows to manage the JTAG debugging process (e.g. load u-boot-spl.bin via 
JTAG, view memory, step, etc).  But I'm having some issues using a 
Windows/VBOX shared folder to contain the u-boot tree so that both the 
Windows and Ubuntu CCS's can look at the same tree/project.

Has anyone on this forum successfully tried this kind of thing before or 
are there obvious reasons why this is a bad idea??  

I think the person in the following thread may have tried something like 


I may post up on TI/E2E, but we're working with the BB-X15 image, not the 
TI SDK image.  I'll try to annotate this thread with any useful information 
that's thrown our way.



For more options, visit http://beagleboard.org/discuss
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to