>>> "Paul" == Paul Eggert <[EMAIL PROTECTED]> writes:
> "Joel E. Denny" <[EMAIL PROTECTED]> writes:
>> They're definitions mostly as opposed to just declarations. I imagine
>> that's why it's called %defines and --defines. So, I decided %pre-defines
>> and %post-defines makes more sense.
> This all sounds OK (in that I can't simplify it much more :-) except
> that the names are still confusing. "%pre-defines" sounds like
> predefined symbols, but then "%post-defines" would be -- what --
> postdefined symbols?
> How about if we call them both "%defines" and decide which is which
> depending on context? That would match %{...%}'s behavior.
Since we are looking for a new syntax, I would prefer to make it
clearer and independent of the order. For a start, it will also help
make things more understandable when we have an %import feature.
To gain in symmetry, we could also used pre-union and post-union?
Bah. Dunno.