Le 16 juin 06 à 18:32, Joel E. Denny a écrit :
On Fri, 16 Jun 2006, Akim Demaille wrote:
"Paul" == Paul Eggert <[EMAIL PROTECTED]> writes:
How about if we call them both "%defines" and decide which is which
depending on context? That would match %{...%}'s behavior.
Since we are looking for a new syntax, I would prefer to make it
clearer and independent of the order. For a start, it will also help
make things more understandable when we have an %import feature.
Although I'm not sure how %import will go, I was also concerned
about how
my first patch would limit it.
The more I think about it, the more I like a simple solution which does
rely on %union to distinguish cases. Even when we have %import we will
still be able to distinguish them.