On 04/03/14 10:44, Bruce Dubbs wrote:
> rhubarbpie...@gmail.com  wrote:
>> On 04/02/14 21:50, Bruce Dubbs wrote:
>>> What's the output of 'echo $PS1'?
>>> How about 'ldd /bin/bash'?  Is libreadline.so.6 there?
>> ldd /bin/bash:
>>      linux-gate.so.1 (0xb7732000)
>>      libreadline.so.6 => /lib/libreadline.so.6 (0xb76f2000)
>>      libhistory.so.6 => /lib/libhistory.so.6 (0xb76ea000)
>>      libncursesw.so.5 => /lib/libncursesw.so.5 (0xb768c000)
>>      libdl.so.2 => /lib/libdl.so.2 (0xb7687000)
>>      libc.so.6 => /lib/libc.so.6 (0xb74dc000)
>>      /lib/ld-linux.so.2 (0xb7733000)
> That's OK.
>> echo PS1: \s-\v\$
> I don't know where this came from.
>> Echo PS1 from LFS shows "\w >" as I would expect.  As I can
>> "./SomeScript.sh" but cannot "source SomeScript.sh" I attempted to
>> manually execute /etc/bashrc from /etc in xterm with ./bashrc but
>> received "file not found."
> Go back to BLFS Chapter 3 and redo the section "The Bash Shell Startup
> Files"
>> This is a stretch, but I should mention I compiled BLFS/X with an older
>> kernel than I used in compiling LFS.  I found I booted to a blank screen
>> after compiling LFS with the 3.13.13 kernel so I reverted to my LFS/BLFS
>> 3.10.10 kernel.  I did post the problem to LFS support "Blank screen
>> when booting with 3.13.3 kernel. - LFS 7.5" but didn't get a resolution
>> and wasn't told I couldn't use an older kernel.  It was a surprise to me
>> I could revert to an older kernel.  I specifically asked the question in
>> my post.  I will re-compile LFS with the 3.10.10 kernel if suggested.
> The kernel has nothing to do with this.
>> I should also mention I've continued past my basic X installation and
>> have no problems other than xterm.  I can run X, connect to the
>> internet, and run all programs I ran with BLFS 7.4 without incident.
> In the problematic xterm, what do you get if you run '. ~/.bashrc'.  The
> dot by itself is important.
> In the problematic xterm, run '/bin/bash' to go into a subshell.  Now
> try running 'source ~/.bashrc'.
>     -- Bruce
Your suggested "~/.bashrc" then "source ~/.bashrc" steps fix the 
prompt.  But I still can't source a script and subsequent xterm windows 
show the old prompt.

I reviewed chapter 3 and "The Bash Shell Startup Files" several times 
before initially posting this problem.  However,  I ran diff's on the 
chapter 3 text and my files:


All but for /etc/bashrc came back with no differences.  Etc/bashrc 
differed with "PS1="\w > " which I earlier referenced.  I knew the 
difference existed and, before posting, ran diff's on the above 
mentioned files on my BLFS 7.4 and 7.5 systems.  My thinking was that if 
they worked with 7.4 they should probably work with 7.5. Regardless, I 
removed anything unique in my /etc/bashrc file and ran a diff between 
the documentation and my /etc/bashrc file with no difference.  I still 
have the "sh-4.2" prompt and can't source scripts.

I mentioned the kernel difference as I'm fully aware this problem is 
almost certainly a mistake on my part.  The kernel switch is the only 
"funky" thing I can think of between 7.4 and 7.5.  I've successfully 
built BLFS many times and I'd hate to have someone help with the problem 
and then learn I had to switch kernels.  Better safe than sorry.

FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to