I've now changed it to this:

#AD Configurations
cas.authn.ldap[0].type=AD
cas.authn.ldap[0].ldapUrl=ldap://alpha.beta.gamma:389
#cas.authn.ldap[0].connectionStrategy=
cas.authn.ldap[0].useSsl=false
cas.authn.ldap[0].useStartTls=false
cas.authn.ldap[0].connectTimeout=5000
cas.authn.ldap[0].subtreeSearch=true

cas.authn.ldap[0].baseDn=dc=beta,dc=gamma
cas.authn.ldap[0].userFilter=cn={user}
cas.authn.ldap[0].bindDn=user@beta.gamma
cas.authn.ldap[0].bindCredential=userPassword

Still not working with the same error.



On Thursday, February 22, 2018 at 1:32:54 PM UTC-6, Kevin Liu wrote:
>
> Hello,
>
> I can't seem to make heads or tailed of getting CAS to talk to LDAP
>
> I know my LDAP is working because using the following command, I can see 
> all LDAP entries:
>
> ldapsearch -x -h alpha.beta.gamma -D user@beta.gamma -W -b 
> "dc=beta,dc=gamma" 
>
> My assumption is that since these credentials are being accepted by LDAP, 
> I just have to configure CAS to use them. Is this correct?
>
> So far, my cas.properties contains the following:
>
> cas.authn.ldap[0].order: 0
> cas.authn.ldap[0].name: LDAP
> cas.authn.ldap[0].type: AD
> cas.authn.ldap[0].ldapUrl: ldap://alpha.beta.gamma:389
> cas.authn.ldap[0].baseDn: dc=di2e,dc=civ
>
> This is not working as I get a ton of errors saying that CAS has not 
> connected to LDAP.
>
>

-- 
- Website: https://apereo.github.io/cas
- Gitter Chatroom: https://gitter.im/apereo/cas
- List Guidelines: https://goo.gl/1VRrw7
- Contributions: https://goo.gl/mh7qDG
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to cas-user+unsubscr...@apereo.org.
To view this discussion on the web visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/1cdff6f8-36ef-4acd-a5b4-ef1b55fa6691%40apereo.org.

Reply via email to