On Wed, 5 Aug 2026 19:02:00 GMT, Naoto Sato <[email protected]> wrote:

>> by1361092 has refreshed the contents of this pull request, and previous 
>> commits have been removed. The incremental views will show differences 
>> compared to the previous content of the PR. The pull request contains one 
>> new commit since the last revision:
>> 
>>   8388366: Launcher test stability regardless of the default locale
>
> test/jdk/tools/launcher/Settings.java line 343:
> 
>> 341:     private static TestResult doExecWithEnglishLocale(
>> 342:         String command, String... args) {
>> 343:         List<String> cmd = new ArrayList<>();
> 
> Allocating `String[args.length + 3]` and directly copying arguments into it 
> would be simpler. Also, I'd prefer the method name as `doExecWithUSLocale`.

@naotoj Thanks for the review.

I have simplified the helper to use a String array directly, renamed it to 
doExecWithUSLocale, and removed the unused imports.

Testing:

- jtreg test/jdk/tools/launcher/Settings.java under zh_CN.utf8: passed

- jtreg test/jdk/tools/launcher/Settings.java under en_US.utf8: passed

Please take another look. Thanks!

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32167#discussion_r3725484832

Reply via email to