Sam,
First thank you for your help.

I figured out part of the problem. courierd wasn't starting. There was a single file the script wanted that I didn't have. I put it in place and courierd at least started.


Now I'm having a problem with "no such file or directory", and the logs report "abnormal program termination". The program restarts every minute, but I'm sure you guessed as much. I figured out via searching (one of your posts actually) that this indicates corruption. I uninstalled, removed the local state directory, then reinstalled. It works fine, right up to the point that I try to send the first message. Then it starts doing that again. I'm at a loss. Currently I'm trying building from source rather than using the package, but if you have more insight into why it might be doing that it would help. At least then I could submit a fixed package for other users.
Joe
On 9/18/2016 14:52, Sam Varshavchik wrote:
Joseph C. Lininger writes:

I installed Courier on Arch Linux  via the aur package. Everything works
fine for the most part. Courier can successfully authenticate against an
SQL database, it can access mailboxes to check mail, etc. One problem,
and it's a big one. When courier receives a message, it doesn't queue it
and deliver it to a mailbox. There's no entry in the logs or anything;
the message just disappears. I also tried sending mail to a remote
location manually by telnetting to the smtp server after temporarily
authorizing localhost to relay. The same thing happens. smtp server
indicates success, but the message is silently dropped. Finally, I've
tried using /usr/bin/sendmail to send a local message. That too doesn't
work. Can anyone shed light on this? I have *never* seen this in over 10
years of using Courier MTA.

The low hanging fruit: has Courier been started? "courier start".

When the server is not running, mail will still be accepted, but not queued up until the server starts.



------------------------------------------------------------------------------


_______________________________________________
courier-users mailing list
courier-users@lists.sourceforge.net
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

------------------------------------------------------------------------------
_______________________________________________
courier-users mailing list
courier-users@lists.sourceforge.net
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

Reply via email to