On 03/18/2017 11:58 AM, Davide Prina wrote:
Firefox dalla versione 52 non supporterà più ALSA. Per i suoni si
appoggerà solo a PulseAudio.


Mi sembra un pelo overhead, in sistemi ove (per un motivo o per l'altro) PulseAudio crea problemi. (cfr. MIPS e PowerPC 64/32).

Inoltre Firefox 52 è il primo browser (non beta e attivato di default) a
supportare a pieno webassembly: nuova tecnologia che permette di
eseguire compilati in diversi linguaggi di programmazione (Es: C, C++,
Rust) e ottenere prestazioni web davvero inimmaginabili fino a poco
tempo fa.
webassembly è uno standard W3C (è ancora in draft) le cui specifiche
sono stare approvate questo mese.


Bisognerebbe pero` valutare (anche se sono meno del 5% di userbase) archittetture ove Firefox > 48 NON GIRANO, per problemi vari (endianness, gecko/webkit issues, et al.) e dove l'implementazione SOLO SOFTWARE BASED di Javascript limita __DI_FATTO__ l'utilizzo pieno della user experience (come si dice al giorno d'oggi).

Fate girare FireFox con una pagina con un javascript un po` complesso e vi trovate BLOCCATI su un UNRESPONSIVE SCRIPT anche su macchine QUAD CORE con clocks che vanno dal 1Ghz in su. A casa ho QuadCore iMX6 1Ghz con 2GB DDR3, QuadCore PPC 970MP AppleG5 @ 2.5Ghz con 16GB DDR2 e scheda PCIE ATI HD4670 ed alcuni siti SONO INACCETTABILI.

Cerchiamo di rendere la base piu` performante PER TUTTI...

E non che siccome i plugins H264 DEVONO essere in HW (tanto per citarne uno siccome si parlava di Flash) ma appoggiarsi (eventualmente) a librerie (magari ottimizzate) esterne.

Insomma, e` giusto cominciare a guardare al futuro ed i tagli vanno fatti, ma tagliare TUTTI GLI UTENTI che (non per colpa loro) devono necessariamente utilizzare sistemi differenti dalle architetture x86_64.

Poi, per completare le informazioni, più o meno tutti i principali
browser non supporteranno più i plugin basati su vecchie tecnologie, ma
si baseranno su una nuova tecnologia webextension che permetterà di fare
un plugin e farlo girare più o meno su tutti i browser (chi crea i
plugin dovrebbe dover fare al più piccole modifiche). L'unico plugin ad
essere supportato per un po' di tempo sarà quello di flash, ma da quello
che ho capito anche lui sarà destinato a breve a non essere più sopportato.
Per chi vuole usare ancora i vecchi plugin fino al 2018 deve usare la
versione di Firefox 52 ESR.

Tutto Firefox sarà poi basato sul linguaggio di programmazione Rust.

altro macello...


--
Eurek s.r.l.                          |
Electronic Engineering                | http://www.eurek.it
via Celletta 8/B, 40026 Imola, Italy  | Phone: +39-(0)542-609120
p.iva 00690621206 - c.f. 04020030377  | Fax:   +39-(0)542-609212

Rispondere a