----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/48520/#review137095 -----------------------------------------------------------
ql/src/java/org/apache/hadoop/hive/ql/metadata/HiveMetaStoreChecker.java (line 390) <https://reviews.apache.org/r/48520/#comment202257> I think it will be a cleaner and more maintanable approach to move this serial code path into a separate function and make the correct function call(i.e. parallel or serial) in getAllLeafDirs(Path basePath, Set<Path> allDirs) based on the value of HIVE_MOVE_FILES_THREAD_COUNT around line 374. This will also prevent creating unnecessary nextLevel queue altogether in the serial code path for each recursive call. i.e. you can make the recursive call inside for loop itself as done in the existing code for serial path instead of adding the item to the queue and then making a recursive call. - Hari Sankar Sivarama Subramaniyan On June 10, 2016, 11:58 p.m., pengcheng xiong wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/48520/ > ----------------------------------------------------------- > > (Updated June 10, 2016, 11:58 p.m.) > > > Review request for hive and Hari Sankar Sivarama Subramaniyan. > > > Repository: hive-git > > > Description > ------- > > HIVE-13984 > > > Diffs > ----- > > common/src/java/org/apache/hadoop/hive/conf/HiveConf.java 285caa3 > ql/src/java/org/apache/hadoop/hive/ql/metadata/HiveMetaStoreChecker.java > 10fa561 > > Diff: https://reviews.apache.org/r/48520/diff/ > > > Testing > ------- > > > Thanks, > > pengcheng xiong > >