I like that idea. It seems much cleaner. Let me give it a try.

On Tue, Oct 11, 2016 at 9:53 PM, Nick Allen <n...@nickallen.org> wrote:

> Does it really need to sudo? Can we do something like "become: false" so it
> doesn't try to sudo?
>
> On Oct 11, 2016 9:33 PM, "Kyle Richardson" <kylerichards...@gmail.com>
> wrote:
>
> > Ok, I think I have the fix for this. With the new local_action logic,
> > ansible is checking the jar path on the host with sudo but doesn't have
> the
> > password. Just need to add the line below to the Vagrantfile.
> >
> > ansible.ask_sudo_pass = true
> >
> > I will test tomorrow and, if successful, open a new PR for the fix.
> >
> >
> > On Tue, Oct 11, 2016 at 8:42 PM, Kyle Richardson <
> > kylerichards...@gmail.com>
> > wrote:
> >
> > > This error could be related to my PR that was merged today (METRON-492
> > > <https://github.com/apache/incubator-metron/pull/302>). I tested this
> > > successfully in a single node vm deployment, but not with vagrant.
> > Perhaps
> > > there is something about vagrant that doesn't like the ansible
> > local_action
> > > logic? I'm trying to reproduce the error now.
> > >
> > > On Tue, Oct 11, 2016 at 7:06 PM, Nick Allen <n...@nickallen.org>
> wrote:
> > >
> > >> Hi Rita -
> > >>
> > >> Yes, I was seeing this same issue today.  I haven't looked into the
> > cause
> > >> yet, but you can comment out that check and proceed with the install.
> > >>
> > >> Doing this from memory, but I believe it is in
> > >> metron-deployment/roles/metron_common/tasks/main.yml.  Comment out or
> > >> delete any task that references the "metron_jar_path" variable.  There
> > are
> > >> two tasks that need commented out.
> > >>
> > >> I will try and get a fix out tomorrow.
> > >>
> > >> On Oct 11, 2016 6:35 PM, "Rita McKissick" <rmckiss...@hortonworks.com
> >
> > >> wrote:
> > >>
> > >> > *** Resending because this message seemed to disappear into the
> ether
> > >> and
> > >> > I didn’t receive a copy of it.
> > >> >
> > >> > I’m having difficulties with the latest Quick Development Platform
> > >> > installation. During deployment I received the following error
> > message:
> > >> >
> > >> > ------------------------------
> > >> >
> > >> > TASK [metron_common : Check for Metron jar path]
> > >> > *******************************
> > >> > fatal: [node1 -> localhost]: FAILED! => {"changed": false, "failed":
> > >> true,
> > >> > "module_stderr": "sudo: a password is required\n", "module_stdout":
> > "",
> > >> > "msg": "MODULE FAILURE", "parsed": false}
> > >> >
> > >> > PLAY RECAP ******************************
> > ******************************
> > >> > *********
> > >> > node1                      : ok=20   changed=2    unreachable=0
> > >> failed=1
> > >> >
> > >> > Ansible failed to complete successfully. Any error output should be
> > >> > visible above. Please fix these errors and try again.
> > >> >
> > >> > ---------------------------------
> > >> >
> > >> >
> > >> > Everything up to this point looked fine.
> > >> >
> > >> > By the way, I installed the latest Quick-Dev installation earlier
> this
> > >> > afternoon and it didn’t install/configure any topologies. That’s
> why I
> > >> did
> > >> > a second install … which turned out even worse.
> > >> >
> > >> > Anyone else having this issue? Can someone help me with a fix or
> > >> > workaround?
> > >> >
> > >> > Thank you!
> > >> >
> > >> > Rita
> > >> >
> > >> > Rita McKissick ! Sr. Technical Writer
> > >> >
> > >> >
> > >> >
> > >>
> > >
> > >
> >
>

Reply via email to