Hi all,


as it seems like everybody agreed on the proposed API Change / extension I 
allowed myself to create an Issue for this to coordinate the work on that under 
https://issues.apache.org/jira/projects/PLC4X/issues/PLC4X-43

I suggest that we move further discussion there.



Is this okay for all of you?

Julian



´╗┐Am 07.08.18, 13:06 schrieb "Julian Feinauer" <j.feina...@pragmaticminds.de>:



    Hi,

    

    

    

    Looks good to me.

    

    

    

    Best

    

    Julian

    

    

    

    Am 07.08.18, 12:53 schrieb "Christofer Dutz" <christofer.d...@c-ware.de>:

    

    

    

        Hi Julian,

    

        

    

        

    

        

    

        well I would propose to add the type suffix with ":{typename}" but 
unfortunately every system has its own types and interpretations.

    

        

    

        

    

        

    

        So our current S7 address would look like this:

    

        

    

        

    

        

    

        DATA_BLOCKS/1/0 --[would be changed to]--> DATA_BLOCKS/1/0:INT

    

        

    

        

    

        

    

        One universal notation for addresses in all drivers will probably not 
work. For example with Modbus the memory block (Coils or Registers) for example 
determins the datatype and with Ethernet/IP for example the address will 
probably look more like:

    

        

    

        

    

        

    

        #2#1#5:INT 

    

        

    

        

    

        

    

        Which means:

    

        

    

        #{classId}#{instanceId}#{propertyId}:{type}

    

        

    

        

    

        

    

        Chris

    

        

    

        

    

        

    

        

    

        

    

        Am 07.08.18, 12:39 schrieb "Julian Feinauer" 
<j.feina...@pragmaticminds.de>:

    

        

    

        

    

        

    

            Hi Chris,

    

        

    

            

    

        

    

            

    

        

    

            

    

        

    

            I guess I'm fine with everything but perhaps we should try to find 
a syntax which goes well for all drivers where this feature is needed.

    

        

    

            

    

        

    

            Could you post an example string for such a suffix?

    

        

    

            

    

        

    

            

    

        

    

            

    

        

    

            And I'm definetly for a "guessing" feature to keep support for the 
current API.

    

        

    

            

    

        

    

            

    

        

    

            

    

        

    

            Julian

    

        

    

            

    

        

    

            

    

        

    

            

    

        

    

            Am 07.08.18, 11:25 schrieb "Christofer Dutz" 
<christofer.d...@c-ware.de>:

    

        

    

            

    

        

    

            

    

        

    

            

    

        

    

                Yeah ... I guess you are right (

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                And regarding Sebastian's suggestion to keep the "it friendly" 
format. I think this shouldn't be a problem. 

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                All we need are more pattern matchers. What we do need however 
is an extension of the existing format to add the type ...

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                Not quite sure if we should prefix the existing strings with a 
type or add them with a suffix.

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                I think I would prefer a suffix ... If we make it a suffix, we 
could make it optional and guess a fitting default type if omitted (same 
behavior as now)+

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                Chris

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                Am 03.08.18, 15:53 schrieb "Julian Feinauer" 
<j.feina...@pragmaticminds.de>:

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    Just a small note to your example, in case of the "DOUBLE" 
we should write LREAL und relly stick to  the TIA naming.

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    Just stating that to avoid confusion.

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    Julian

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    Am 03.08.18, 15:42 schrieb "Christofer Dutz" 
<christofer.d...@c-ware.de>:

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                        This is the Discussion thread, so please perform any 
form of discussion here to keep the vote thread clean and readable.

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                        

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                        Chris

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                        

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                    

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

                

    

        

    

            

    

        

    

            

    

        

    

            

    

        

    

        

    

        

    

    

    


Reply via email to