Ignacy Gawędzki wrote,

> On Thu, Oct 13, 2016 at 09:19:19PM +0200, thus spake Waldemar Brodkorb:
> > If you want you can try it with my embedded-test script (you need
> > mksh and qemu installed):
> > git clone git://git.embedded-test.org/git/embedded-test
> > cd embedded-test
> > git clone git://git.uclibc-ng.org/git/uclibc-ng
> > mksh embedded-test.sh --arch=mipsel --libc=uclibc-ng \
> >   --libc-source=uclibc-ng --test=libc
> > 
> > Only 3 tests should fail.
> > Then apply your patch and run it again, it will automatically
> > do a complete clean build.
> Okay I did this several times yesterday.  On the first attempts, 11
> tests failed without my patch vs. 12 with it.  The additional test
> that failed with my patch was nptl/tst-cancelx10.  I started
> investigating what could possibly go wrong and tried several things,
> from running the binary with qemu-mipsel to logging into the vm used
> for tests and running the test from there.  It seemed at first that
> with my patch the binary got killed with SIGABRT.  I re-ran
> embedded-test.sh several times in the process and at some point
> noticed that the SHA-1 for openadk is not the same.  Since that
> moment, I re-ran embedded-test.sh with a pristine setup in both cases
> (with and without my patch).  Now in both cases I have 11 failed tests
> and nptl/tst-cancelx10 doesn't fail.
> So I'm wondering whether anything in openadk could have changed in the
> meantime that makes the tests work well in both cases.
> Could you please run the tests again yourself to check this?

I tested again. With uClibc-ng master i get exactly 3 errors.
Tried three times.

With your patch I get sometime 11 or 12 errors. Seems a timeout

What version of Qemu are you using?

qemu-system-mips -version                                                       
QEMU emulator version 2.6.1, Copyright (c) 2003-2008 Fabrice Bellard

We recently had issues with the testsuite build without the full gcc
and I thinking of separating the testsuite to its own project.

OpenADK does not change between runs of embedded-test as long as
you don't use --update.

Are you sure you use uClibc-ng fresh checkout and referencing the
directory with --libc-source? 1.0.18 release would have 11/12
errors, which is the fallback when no special directory is used.

best regards
devel mailing list

Reply via email to