On 23/02/2015 8:01 p.m., Namespace wrote:
On OSX you can load either "legacy" version of OpenGL so 1.x/2.x or
3.x+. Not both. I found this out for Devisualization.Window. Most
likely dgame by default is loading it in legacy mode.

Derelict GL is loading in legacy mode. You have to call 'reload' after
creating a valid GL Context to update your OpenGL to the highest
possible version. Maybe that doesn't work on Mac?

This does work on OSX. Again Devisualization.Window supports OpenGL context creation for both "legacy" and non "legacy". It is just dependent upon what you specify as the version to load when creating the context that matters.

Reply via email to