Hi Slawomir, Slawomir Grochowski <[email protected]> writes:
> After giving it some more thought, I think the simplest solution is to > rename the existing user options as follows: > > - org-checkbox-hierarchical-statistics' to > org-checkbox-direct-children-statistics' After a good night sleep, I understand why I prefer "non-recursive" over "direct-children". A value `nil' for the "non-recursive" variant clearly means "recursive", while `nil' for "direct-children" is unclear to me (what are "indirect children"?) > - Org-hierarchical-todo-statistics' to > org-todo-direct-children-statistics' Same here. > When adding recursive checkbox collection to column-view summaries, I > would also introduce: > > - `org-columns-checkbox-direct-children-statistics' > > This preserves the existing polarity, makes the non-nil behavior > explicit, and allows us to retain the old names as ordinary obsolete > variable aliases. Yes, that's clearly the right direction IMHO. > Would you agree with proceeding this way? Not my call to make, I'm just bikeshedding a little bit here :) Thanks! -- Bastien
