Hi Bastien,

Thanks. Your question about “indirect children” made me reconsider the
proposed names. Perhaps dropping “direct” and adding “only” would
provide a clearer compromise:

- rename org-checkbox-hierarchical-statistics' to 
org-checkbox-children-only-statistics';
- rename org-hierarchical-todo-statistics' to 
org-todo-children-only-statistics';
- add `org-columns-checkbox-children-only-statistics' for column-view summaries.

Org already uses “children” for entries one level below their parent,
for example in org-fold-show-children', org-list-get-children', and the
“CHILDREN” visibility state as opposed to “SUBTREE”.

The “only” qualifier would make the non-nil behavior explicit:
statistics are restricted to children only. With nil, that restriction
is not applied, so statistics cover the entire subtree recursively. This
also preserves the existing polarity and avoids the double negation
involved in setting a “non-recursive” option to nil.

Would these names address your concern?

-- 
Slawomir Grochowski

Reply via email to