I see no reason to name the "floordiv" trap that way. Python has a good reason: they have more than one division operator (/ and //). The reason for it is that, at the beginning, the division operator behaved just like that of C: 1/2 gave 0, not 0.5. But Javascript already give the more accurate value, so there is no need for two operators.
I therefore suggest naming this trap "div". >There is a current strawman at < >http://wiki.ecmascript.org/doku.php?id=strawman:value_proxies>. I like the >direction it is headed. _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

