On Sun, Jan 9, 2011 at 11:51 PM, thaddee yann tyl <[email protected]> wrote: > I see no reason to name the "floordiv" trap that way. Python has a > good reason: they have more than one division operator (/ and //). > The reason for it is that, at the beginning, the division operator > behaved just like that of C: 1/2 gave 0, not 0.5. > But Javascript already give the more accurate value, so there is no > need for two operators. > > I therefore suggest naming this trap "div".
Good point, thanks. I've incorporated this suggestion. - Cormac _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

