On Jul 16, 2008, at 11:35 AM, Allen Wirfs-Brock wrote:

> I could live with lookup, although I think it focuses the meaning  
> on the access process rather than on the result. Another, slightly  
> longer alternative would be "retrieve".

What do you say to Ingvar's suggestion of "inspect"?

> Regarding, what getOwnProperty returns, what you currently see in  
> the spec. is probably a bug.

Are you tracking these somewhere? I think bugs.ecmascript.org is a  
fine way to keep trac(k). :-)

> My intent was for it to return undefined, although somebody more  
> steeped in JavaScript idioms could convince me that null is more  
> appropriate if that really is the case.

JS has two bottoms: null means no object and undefined means no  
value, so for this kind of "descriptor object if property exists,  
else bottom" API, null is better.


Es4-discuss mailing list

Reply via email to