(I'm not going to get you to take the bait on "reify", am I?) I think I like "describe" better than "inspect" for no particularly tangible reason, although it does have more characters. I generally find the Thesaurus a useful tool in this process and it turned up "depict" which is shorter but also seems to capture the same core distinction as "describe".
I think that the currently named getOwnProperty is more fundamental than getProperty so in considering length we should probably use the former as our benchmark. BTW, I'm open to arguments that we don't really need getProperty (as long as getPrototypeOf is kept). (Oh shit ... do we need to rename that one, too??) I think we've pretty much covered the "name space" and would be content, at this point, to sit back for a few days and see if anybody else is brave enough to argue for one name over another. If not I think we can reach agreement on one of these that we have been discussing. Allen -----Original Message----- From: Brendan Eich [mailto:[EMAIL PROTECTED] Sent: Wednesday, July 16, 2008 11:52 AM To: Allen Wirfs-Brock Cc: [EMAIL PROTECTED] x-discuss; email@example.com es4-discuss Subject: Re: ES3.1 Object static methods rationale document On Jul 16, 2008, at 11:44 AM, Brendan Eich wrote: > On Jul 16, 2008, at 11:35 AM, Allen Wirfs-Brock wrote: > >> I could live with lookup, although I think it focuses the meaning >> on the access process rather than on the result. Another, slightly >> longer alternative would be "retrieve". > > What do you say to Ingvar's suggestion of "inspect"? Or (drum roll) "describe": describeProperty, which returns a property descriptor. /be _______________________________________________ Es4-discuss mailing list Es4firstname.lastname@example.org https://mail.mozilla.org/listinfo/es4-discuss