On Wed, Jul 16, 2008 at 1:41 PM, David Flanagan <[EMAIL PROTECTED]> wrote:
> Brendan Eich wrote:

> Frankly, though, I imagine that defining properties will be more common
> than reflecting on them, and I don't see anything wrong with a long name
> that explicitly describes the function: getPropertyDescriptor(),
> lookupPropertyAttributes() or whatever.

I agree. 'getPropertyDescriptor' sounds more descriptive. Allen's doc
calls the return an "attributeDescriptor" but "propertyDescriptor"
seems to be a more descriptive term.


>        David Flanagan
Es4-discuss mailing list

Reply via email to