I see two LM classes that appear misnamed, which can
cause confusion as to their purpose:

1.) FlowLayoutManager is defined as "the layout
manager for an fo:flow object" -- but actually it can
also be for an fo:static-content object if the static
content is directed to the region-body of the page.

Further, the class processes a single
normal-flow-reference-area (i.e., a column) within a
span-reference-area of the region-body of the page[1].
 In other words, the processing of an fo:flow actually
could take *several* of these objects if the span is
multi-column, or its output takes several pages.  So I
think FlowLayoutManager should be renamed to

2.)  Similarly, the StaticContentLayoutManager should
be renamed to SideRegionLayoutManager, because the
output of both fo:static-content and fo:flow can be
directed to it, also fo:static-content can actually
end up being rendered by NormalFlowLayoutManager(s) if
(1) above occurs.

Any objection to the two renamings?



Reply via email to