Soren Schmidt <[EMAIL PROTECTED]> writes:

> It seems Geoff Rehmet wrote:
> > Brian McGroarty writes :
> > > In using the ATA driver, I'm unable to automatically mount a
> > > partition on a master drive on the secondary controller. fsck
> > > complains that device rwd2s1e isn't configured and exists.
> > > Immediately mounting by hand works perfectly.

> > I had exactly the same problem, although it manifested itself with a
> > secondary master or slave.  It went away a few weeks ago, and I
> > was never able to make any sensible progress in tracking the problem
> > down.
> Hmm, damn, after the problem went away for Geoff I thought it to be
> solved since I've never heard of it anywhere else, and I cant reproduce
> it here no matter what I try.
> Does it help eany if you only has the root partition use the wd dev
> and have the rest use the prober ad dev entries ?? It could be some
> artifact from this...

I tried with the ad dev entries for my problem as well with no
improvement.  I've also tried using: 
  dd if=/dev/ad0s6 of=/dev/null bs=512 count=1
as the first access to one of the failing drives (ad0).  
The first dd fails with device not configured, but any subsequent
access works fine. It seems it's left in an odd state by the driver
start up, but all it takes is a read to get it sorted out again.

Any thoughts on how we can help debug this?
Kevin Street

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to