I just rebooted on an August 11 kernel.  My system
still is happy with the disks.  Hmm.

I can't remember exactly where my tracing went, before I
left off before, but the message you are seeing comes from
/sys/i386/isa/diskslice_machdep.c, line 200 (version 1.35).

What you will probably find, is that if you put a line that

goto reread_mbr

instead of "goto done", you will find that, on the second
attempt, it reads the mbr successfully.
The above is a severe kludge, and that is why I never committed
any code to do anything of the sort.  I think the error is
actually somewhere in the ATA code (sorry Soren).  I don't
want to patch around a bug.

Now somebody remarked that after the probe, a drive status
light stayed on - maybe, the probe is not doing something
properly for some drives, or there is somethign timing out.

> -----Original Message-----
> From: Kevin Street [mailto:[EMAIL PROTECTED]]
> Sent: 12 August 1999 03:10
> To: Soren Schmidt
> Subject: Re: ATA - Trouble mounting secondary master
> Kevin Street <[EMAIL PROTECTED]> writes:
> > Soren Schmidt <[EMAIL PROTECTED]> writes:
> > > Hmm, damn, after the problem went away for Geoff I 
> thought it to be
> > > solved since I've never heard of it anywhere else, and I 
> cant reproduce
> > > it here no matter what I try.
> > > Does it help eany if you only has the root partition use 
> the wd dev
> > > and have the rest use the prober ad dev entries ?? It 
> could be some
> > > artifact from this...
> > 
> > I tried with the ad dev entries for my problem as well with no
> > improvement.  I've also tried using: 
> >   dd if=/dev/ad0s6 of=/dev/null bs=512 count=1
> > as the first access to one of the failing drives (ad0).  
> > The first dd fails with device not configured, but any subsequent
> > access works fine. It seems it's left in an odd state by the driver
> > start up, but all it takes is a read to get it sorted out again.
> More on this.  
> I just booted with -v and now when I do the first dd I see:
>   ad0: invalid primary partition table: no magic
> and the same on ad2 when the swapon fails.  
> So how do I get the magic back into my relationship with my drives?
> -- 
> Kevin Street

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to