On Thu, 12 Feb 2009 00:44:19 -0500, Robert Huff <roberth...@rcn.com> wrote:
> Polytropon writes:
> >  I'd like to ask how to determine which process (or program) keeps
> >  a partition in state "busy" so that umount will refuse to unmount
> >  this partition. 
>       The traditional tool for doing this is sysutils/lsof.
>       (Please let me know if it compiles.)

Sadly not, but my Ports tree is not up to date, so I tried to compile
it in PORTVERSION=4.82A, with this error:

===>  Building for lsof-4.82A,3
(cd lib; make DEBUG="-O2" CFGF="-fno-strict-aliasing -pipe -march=pentium4 
-march=pentium4 -DHASEFFNLINK=i_effnlink -DHASF_VNODE -DHASCPUMASK_T 
cc  -fno-strict-aliasing -pipe -march=pentium4 -march=pentium4 
-I/usr/src/sys -O2 -c ckkv.c
In file included from ckkv.c:33:
../machine.h:62: error: redefinition of typedef 'cpumask_t'
/usr/src/sys/sys/types.h:146: error: previous declaration of 'cpumask_t' was 
*** Error code 1

Stop in /usr/ports/sysutils/lsof/work/lsof_4.82A.freebsd/lib.
*** Error code 1

Stop in /usr/ports/sysutils/lsof/work/lsof_4.82A.freebsd.
*** Error code 1

Stop in /usr/ports/sysutils/lsof.

After I updated my Ports (just right now) I saw that lsof didn't change,
still same version number.

Installation via pkg_add -r worked without problems.

# pkg_add -r lsof

I've got lsof-4.82A,3 now. The manpage reveals that this seems to be
exactly what I've been searching for, so "lsof | grep usr" should to
the trick. Thanks!

>From Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to