> I have created a log file using dmesg, but, I am
> unable to copy on to the
> floppy disc. When I try to mount the floppy with
> mount /dev/fd0 /mnt, it
> gives me error message: Device is not configured.


mount -t msdos /dev/fd0 /mnt

with any DOS formated disc. 
If you want to mount a UFS partition/floppy, you have
to create actually the FS structure first using newfs
(but you will not be able to easily read it from Win
:) ).

% man 1 fdformat 

Note that fdformat does only perform low-level
formatting.  In order to create a file system on the
medium, see the commands newfs(8) for a UFS file
system, or newfs_msdos(8) for an MS-DOS (FAT) file

Mount expects a file system structure on that disc
(either UFS or DOS).

> I formatted the floppy using fdformat command, and
> when tried to mount, it
> gives me error message "incorrect super block". Now
> this format is not
> copatible with windows system.

No file system present (in this case, mount tried to
mount the default ufs FS, which expect to start with a
superblock, which is not there, as you haven't
newfs-ed the disc).
> I also created another dos fat partition and tried
> to mount so that I could
> copy the log file to dos partition, it won't work. I
> have used this method
> to transfer the files on a Linux system.

Again, see above (newfs(8)). If you formated as type,
again, use -t msdos to specify the type (default is

> Is there a way to transfer files from FreeBSD to
> Windows?

Simple way:) : new floppy (preformated in old DOS/IBM
format), insert, "mount -t msdos /dev/fd0 /mnt"
, copy the stuff, "umount /dev/fd0", extract, go to


PS. In case of errors, check if you have the /dev/fd0
device actually. You should, if your drive is
recognized during boot.
PS2. Maybe you want to take a look at www.onlamp.com,
they have many nice written tutorials about FreeBSD to
put you on track.

Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to