On Friday 09 April 2004 11:55 am, Andreas Davour wrote:
> Hi!
>
> I just decided to take a deep breath and cvsup some fresh ports. Now,
> having done that I have run 'portupgrade -ar' and constantly found it
> to stop some problems.
>
> Some ports have failed and been flagged as "configure error" or
> "install error". Then I have tried to do a manual install of those
> ports and found that a "make deinstall; make reinstall" have worked,
> just like the port instructed me to do when it failed. I found it
> strange that portupgrade didn't do that for me.
>
> Having done that I restarted portupgrade and it would proceed a bit
> before stumbling to a halt again.
>
> Now I have reached the end of what I can fix manually, though. For
> some reason portupgrade stubbornly complains that:
>
> "** Listing the failed packages (*:skipped / !:failed)
>         ! accessibility/atk (atk-1.4.1_1)       (port directory
> error)"
>
> And it is correct in that there *is* no accessibility/atk port in my
> new cvsup'ed ports tree. But why is it then telling me it needs it!?
>
> Can I get the atk ports from somewhere? Is it really needed? Why has
> it dissapeared and why is it still mentioned as a dependency then?
>
> If anyone can shed some light on those matters, then I'm all ears. I
> can't get a new version of Firefox to compile without atk so I'm very
> interested in getting this to work.
>
> I have run 'pkgdb -F' and tried to remove the dependecy, but have not
> succeeded. I'm not even sure it would be wise to do it...
>
> Help?

Firefox depends on gtk-2.4.0, which depends on atk. All of these 
problems relate back to updating dependancies of glib-2.4.0.

The question at this point is what you updated and the order. If you 
were starting out clean, a portupgrade -rR glib would have done most of 
this but I wouldn't bet money. I eventually did a -rf glib to get 
things built cleanly.

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to