On 11/15/2012 11:41 AM, Adrian Chadd wrote:
On 15 November 2012 09:24, Joshua Isom <jri...@gmail.com> wrote:

So I'm taking it that currently it will not work without the glue that's not
yet available?

I'm trying to get ndis working, but it's failing to find the device.  I can
run pciconf -lv and it shows that it's connected.

The glue is available. The HAL isn't available. That's the missing piece.

As for NDIS, I haven't ever played with that. Sorry. I'm trying to
make the drivers support everything so we don't need NDIS.

What's the PCI ID of the chip you're using, and which driver are you
trying to use with NDIS?


I tried doing a mix of ath from -current and the rest from -stable but it wouldn't compile because of iwn and other issues. I tried doing a -current generic kernel. It would kernel panic shortly after getty was started but I think that's another issue. After I got it to not panic, the ath driver still wouldn't attach. Here's the relevant output of pciconf.

none3@pci0:2:0:0: class=0x028000 card=0x3112168c chip=0x0030168c rev=0x01 hdr=0x00
    vendor     = 'Atheros Communications Inc.'
    device     = 'AR9300 Wireless LAN adaptor'
    class      = network

I was trying drivers off the CD I was given by the vendor. The card is a TP-LINK TL-WDN4800. I tried the XP and Vista drivers, athwx.sys and athrx.sys, but neither had any effect.

freebsd-wireless@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to