Follow-up Comment #10, bug #18517 (project freeciv):

Sorry for the delay. Unfortunately, I've got no extra data on this bug.

I couldn't get freeciv-gtk2.exe to run with any of the winstacks at all
(2165/2180/2189) -- nothing happened when I ran it from the command prompt.

This is similar to what happens if I forget to run setup.bat from winstack. I
noticed that setup.bat was slightly wrong in all of these winstacks,
presumably due to the gdk-pixbuf difference you mentioned; setup.bat tries to
run:


bingdk-pixbuf-query-loaders.exe > libgdk-pixbuf-2.02.10.0loaders.cache


but libgdk-pixbuf-2.0 doesn't exist.

libgtk-2.0 looked like a plausible replacement (containing 2.10.0loaders
folders), so I tried running the above command with "gtk-2.0" replacing
"gdk-pixbuf-2.0", but it didn't help. I also tried manually creating
libgdk-pixbuf-2.02.10.0.

freeciv-sdl.exe and freeciv-server.exe were fine (the latter with a warning
"exchndl.dll could not be loaded, no crash debugger"), but that doesn't help
us here :(

> You may want to test also if combination of above freeciv 
> compiled against gtk+ 2.16.5 (compatible with any gtk2 version 
> above 2.16.5) and dllstack binaries with later gtk+ version 
> work (I would be very surprised if it would, but...)
As you expected, it doesn't work. All of freeciv-{gtk2,sdl,server} die with
errors like:


---------------------------

freeciv-gtk2.exe - Entry Point Not Found

---------------------------

The procedure entry point libintl_setlocale could not be located in the
dynamic link library libintl-8.dll. 

---------------------------

OK   

---------------------------


    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?18517>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to