Follow-up Comment #12, patch #4374 (project freeciv):

> I guess that this involves changing m4/qt.m4?
I planned making a version that took the Qt version as a parameter. I believed
that qt.m4 was "generic Qt". Now that I realize that qt5.moc is based on
qt.moc your patch looks like the correct approach.

>  Arguably we should either fix qt.m4 or remove it from svn (in which case
I'll keep a local copy). 
Agreed.

> FWIW, attached my local Qt4 version of this patch to restore my own ability
to build with Qt4; don't know if this is the best way to do it.
Looks OK. Do you wish it to try using qtchooser to find the Qt 4 moc when the
"moc" command is the Qt 5 version? If you do add back the code you removed but
change "qtchooser -run-tool=moc -qt=5" to "qtchooser -run-tool=moc -qt=4".

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?4374>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to