Picking up on this topic, I ran into a serious problem today when trying to use the FreeDOS SYS command to fix the problem discussed below.


Except I'd completely misunderstood the command line options for my version of FreeDOS SYS and what it can and can't do! See below...

4. SYS a: c: BOOTONLY (put FreeDOS bootsector onto c: drv)
5. Start Windows real-mode setup program

Here is where it goes BADLY wrong! When the system reboots, it tries to boot the C drive, and gives the following error on a black screen:

Disk Error
Press any key to restart

This is still a mystery.

As an experiment (before this last step) I decided to use FreeDOS SYS to replace the "broken" NT boot sector to see if it would fix it. FreeDOS SYS has an option to grab a 512b boot sector from a file and write it to a drive (very nice),

No it does not! At least not the version I'm using. I'd misunderstood the help strings when typing SYS /?

I'd seen the stuff about "boot sector files", and assumed it was offering to write boot sectors to my hard drive partition. After reading the text more carefully, it's actually offering to write the _FreeDOS_ boot sector to a disk file! That's not the same at all, and explains why my boot sector never got changed.

The SYS command did it's thing, and reported the new boot sector had been installed, but when I tried to boot the C: drive, it did NOT look like the NT boot sector! It was saying "FreeDOS can't find KERNEL.SYS". Hmmm, something not right there.

Yes, it had installed the _FreeDOS_ boot sector and kindly also written it to a disk file for me, DUH!

Here are my versions:

KERNEL 1.1.35 (Build 2035-cvs) June 16 2005
SYS v3.2 June 2005

--
Gerry Hickman (London UK)


-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to