Ulrich,

Sorry about the delay here - my email stacks up way too quickly and I 
miss some at times. Comments are inline:


On 5/25/2011 9:54 AM, Ulrich Hansen wrote:
> Hi Michael,
>
> thanks a lot! I tried the ftpsrv app with Filezilla and it works much
> better now (I missed the update before, so maybe this is not really
> news).
>
> Directory browsing with Filezilla as FTP client and mTCP ftpsrv as
> server seems to be no problem anymore. Thanks!
>
> And I especially like the precise logging of events to the screen of
> the DOS machine. I miss this in WATT32 ftpsrv32.
>
> Unfortunately there still seem to be some issues of mTCP ftpsrv with
> Filezilla:
>
> 1. When I try to copy a file with a long filename in Filezilla to the
> FreeDOS machine mTCP ftpsrv will not store it. Instead it responds
> with "550 Bad path". Filezilla translates this to "Critical error". In
> comparison, WATT32 ftpsrv32 stores it anyway and lets FreeDOS cut the
> name.

I aggressively parse the file and path to ensure that they are valid and 
are not going to cause buffer overruns.  I'm kind of paranoid about 
buffer overruns, especially since so many versions of DOS can be used.  
(I've tested on everything from PC 2.1 up to DOSBox's emulation of 
DOS.)  I could truncate the requested filename, but I think that 
returning the error is the more proper thing to do.

> 2. Another behaviour I saw: Successfully copied files are sometimes
> not listed automatically in the right window with the files on the
> server in Filezilla. So sometimes I have to push the refresh button.

A comparison of the trace from an FTP server that works and mTCP would 
tell me what is going wrong.

> 3. Filezilla seems to show a random date of the files I copied to the
> server (neither the original date nor the actual one). If I stop the
> server and check them in FreeDOS the copied files have the actual date.

This probably requires a trace too, although it pleases me greatly that 
the file timestamps are correct.  Have you tried using another FTP 
client to "peek in" while FTPSRV and Filezilla are still active?

> 4. If I try to copy a file that already exists on the server, ftpsrv
> responds with "553 File exists already" which causes Filezilla to stop
> the transfer and say "Critical error". By default Filezilla should
> open its dialogue window which asks if I want to overwrite, rename or
> keep the duplicate on the server.

Well, the file does exist.  The proper action is to delete the file on 
the server first, and then start again.  I could be wrong but if the 
ftpserver just clobbered files (overwrite) without complaining that 
would lead to more problems with partial files overlaying good ones.
> Sorry to report this. Most of these bugs may relate more to Filezilla
> than to your FTP server. I work with Filezilla 3.3.1 in Ubuntu 10.04
> LTS and use freedos in Virtualbox.
>
> BTW I have updated the mtcp files in the virtualbox image at
> http://lazybrowndog.net/freedos/virtualbox/
>
> :-)
>
> thanks again, regards
> Ulrich Hansen
>
Thanks!  I refer people to that fairly often - it is a good FreeDOS and 
networking sampler.


-Mike



------------------------------------------------------------------------------
vRanger cuts backup time in half-while increasing security.
With the market-leading solution for virtual backup and recovery, 
you get blazing-fast, flexible, and affordable data protection.
Download your free trial now. 
http://p.sf.net/sfu/quest-d2dcopy1
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to