Hi Bret,

I'm sorry. I didn't read your email before writing to the list again.
this time I tried everything I could think of before posting.

current status:
I made both, the keyboard and the mouse work once, but not stable yet.
If you wish I can help in trouble shooting/debugging the drivers.

Am 06.06.2012 18:27, schrieb Bret Johnson:
>> I tried Bret J.'s USB driver. USBUHCI loads, but complains about
>> legacy USB mode. Do I have to switch off legacy in BIOS?
> You shouldn't have to, but that's certainly an option.  

switching off legacy in bios did not change anything.
(except of course the usb keyboard does not work before loading the USB

>> after the driver is loaded, the keyboard does not work any more.
>> loading USBKEYB afterwards does not help.
> How are you able to load USBKEYB afterwards if the keyboard doesn't work?

i used a batchfile *g*
should I delay loading device drivers after USBUHCI?

>> Since the docs are for people who want to deal with every bit
>> that is sent over USB... Is there a short how-to available?

when I am finished i'll try to write a short guide that will answer most
of my beginners questions.

> Your most likely problem is that you have more than one UHCI host controller, 
> and you are only installing the driver for the first one, but your keyboard 
> is not plugged into the first one. 
> You can use USBHOSTS to tell you how many USB host controllers you actually 
> have.

I have got 3xUHCI (1x Intel, 2xVia).
There is an EHCI controller, but it's offboard so I am sure I did not
plug anything into these ports. (btw, don't know how to load the driver
for this host, since it has #0, too)

I used USBDEVIC to check if there are devices on the host:
just now it reports both, mouse and keyboard for host #0 (intel).
after loading ctmouse the mouse works, but the keyboard doesn't.

edit: when legacy is off, the keyboard LEDs turn on when loading USBUHCI
#0, and off when unloading.

once the devices were listed at host #1 (via)
in this case, the keyboard worked, but loading usbmouse crashed the system.
could not yet reproduce this config.

what about the message: "initilizing ps/2 mouse"
if this message is shown has nothing to do with a mouse attached or not.

Still I got the problem with the PS/2 keyboard.
As soon as the USBKEYB is loaded, roughly every second keypress shows
two letters. This seems to be true for printable characters only.


Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
Freedos-user mailing list

Reply via email to