Hi Phil,

The best way to make sure you're up to date is to run the Direct X Web Installer from Microsoft, but I can certainly provide this on my website as well for people to download. I will also include it if I ever make a Blastbay Games CD.


Kind regards,

Philip Bennefall
----- Original Message ----- From: "Phil Vlasak" <p...@pcsgames.net>
To: <phi...@blastbay.com>; "Gamers Discussion list" <gamers@audyssey.org>
Sent: Friday, March 04, 2011 11:54 AM
Subject: Re: [Audyssey] XAudio2 and BGT


Hi Philip,
I would like you  to change to XAudio2, but would it be possible to have
links to those Direct X 9 and Windows 7 updates that you suggested?
I have Vista and have updated to the latest service pack.

thanks,
Phil


----- Original Message ----- From: "Philip Bennefall" <phi...@blastbay.com>
To: "Gamers Discussion list" <gamers@audyssey.org>
Sent: Friday, March 04, 2011 3:03 AM
Subject: [Audyssey] XAudio2 and BGT


Hi all,

Recently I have been making some drastic changes to the BGT core. As many
of you will know, most audio games today use a technology known as
DirectSound to output audio. BGT is no exception. Until about 3 years ago
DirectSound was the interface of choice for all Windows based games. It
has been around since 1995, and has become rather stable over the years.
However, Microsoft are now pushing developers away from DirectSound as it
is being replaced by a new audio engine called XAudio2. XAudio2 provides
much greater flexibility when it comes to low latency audio processing,
and is an over-all better system than DirectSound. However, in order for
XAudio2 to work reliably I have found that the end users need to run at
least the June 2010 release of Direct X 9. It is also necessary for users
of Windows 7 service pack 1 to upgrade in a few cases.

So my question to you all is this. In the next BGT release, would you like
me to switch to XAudio2? This will give much better performance on Windows
Vista and 7 as compared to DirectSound, but should be about the same on
Xp. However, the games simply will not run if the user has anything
earlier than Direct X June 2010 installed and it will force them to
upgrade. Do I maintain two versions of the engine for a while, a
DirectSound and an XAudio2 build, or are we okay to switch immediately?
This is what I would like to ask you all before I make a final decision.

Thanks for reading.

Kind regards,

Philip Bennefall
---
Gamers mailing list __ Gamers@audyssey.org
If you want to leave the list, send E-mail to
gamers-unsubscr...@audyssey.org.
You can make changes or update your subscription via the web, at
http://audyssey.org/mailman/listinfo/gamers_audyssey.org.
All messages are archived and can be searched and read at
http://www.mail-archive.com/gamers@audyssey.org.
If you have any questions or concerns regarding the management of the
list,
please send E-mail to gamers-ow...@audyssey.org.


-----
No virus found in this message.
Checked by AVG - www.avg.com
Version: 10.0.1204 / Virus Database: 1435/3479 - Release Date: 03/03/11



---
Gamers mailing list __ Gamers@audyssey.org
If you want to leave the list, send E-mail to gamers-unsubscr...@audyssey.org.
You can make changes or update your subscription via the web, at
http://audyssey.org/mailman/listinfo/gamers_audyssey.org.
All messages are archived and can be searched and read at
http://www.mail-archive.com/gamers@audyssey.org.
If you have any questions or concerns regarding the management of the list,
please send E-mail to gamers-ow...@audyssey.org.

Reply via email to